Digitalsystem

25.01.2022 – Lösung & Erkenntnis

Zimo hat eine Antwort mit einem cfg-File gesendet, das mich doch sehr verwundert hat. Darauf wäre ich NIE gekommen, weil es wie vieles andere auch leider nirgends in der Doku steht.

  • beim GATYP ist “GA-FE-KSA” statt nur “KSA”  zu verwenden
    – OK, bedingt  nachvollziehbar
  • beim APUGA muss Moduladresse.AnschlussNR und dann OHNE LEERZEICHEN dazwischen KS stehen z.B. 13.7KS
    – AHA 🙂
  • Zeile für die Kehrschleife ersetzt die normalen GATYP Eintrag – ist weil 2 benützt werden, auch 2 mal einzutragen.

Zum Laden der Konfiguration habe ich auch noch eine wesentliche Erkenntnis gewonnen.

  • Die Moduladresse muss mit der Adresse beim APUGA, APUANTR im cfg-File übereinstimmen, sonst wird die Konfiguration nicht geladen.
  • Danach kann die Moduladresse geändert werden, die Konfiguration behält die Gültigkeit.
    D.h. es wird nicht das gesamte cfg-File im StEin gespeichert, sondern nur jene Teile die zum Zeitpunkt des Laden mit der Moduladresse übereinstimmen.
  • Somit ist es möglich auch ohne MODULNR (noch nicht implementiert) ein cfg-File für mehrere Module zu haben. Module haben ihre Adresse und entnehmen im Zuge der Multi-Konfiguration ihre Daten aus dem aktuell eingespielten File.

23.01.2022 – StEin  und die Kehrschleifen

Zahlreiche bis unzählige Versuche haben nichts gebracht. Ich konnte keine Kehrschleife in Betrieb nehmen. Folgendes habe ich in allen nur erdenklichen Kombinationen probiert:
@Spalten: mit und ohne die beiden ersten Spalten 
@APUGA (Anschluss) mit “M” und Moduladresse probiert
@GATYP: GAZIMEN18 (Zimo Demo Anlage), GA-MU-STW(Anleitung Seite 36), GA-FE-NNK (Anleitung Seite 23 – NNK wäre Auslieferungszustand)
@Zeilen: KSA Information einmal nach dem Modul (M.8) , zweimal nach dem Modul (M.7 & M.8) und zweimal statt den entsprechenden Zeilen für das Modul
@KSA: mit GA-Typ und ohne

Eine Anfrage an Zimo vom 21.1.2022 betreff der richtigen Konfiguration blieb bis dato  (24.01.2022) unbeantwortet.

Meine Vermutung ist, dass das auch noch nicht implementiert ist, da bei Auswahl einer Fertig-Konfiguration im Falle der Auswahl für die Kehrschleife keine Reaktion des Modul zu bemerken ist.

17.01.2022 – Die Module sind wieder da

Erkenntnisse & Feedback von Zimo:

  • Der Modus für die EPL-Weichen ist noch nicht implementiert. Als Ersatz kann die Einstellung für die Motorweichen genutzt werden mit der Änderung von ein paar Zeiten
  • Die SW (aktuell 7.1.94) ist nach wie vor auf der Homepage aber hat Fehler – Downgrade bei meinen Modulen auf 7.1.81. 
  • Die cfg-Files und Vorlagen sind falsch, man muss die beiden ersten Spalten (Name & Modulnummer) weglassen, damit es funktioniert. Das cfg-File der Demoanlage wurde nicht so verwendet wie publiziert. 
  • Die Auswahl des elektrischen Anschluss bzw. die Moduladresse funktionieren derzeit definitiv nicht. 
  • Stand 21.01.2022

Die Weichen funktionieren einmal, damit kann dieser Punkt vorerst abgehakt werden. Ein paar nette Features wären noch fein, wie z.B. die Stellungserkennung.

Als nächstes plane ich die Gleisabschnitte mit einer Kehrschleife in Betrieb zu nehmen, vielleicht klappt das auf Anhieb – ich glaube es nicht.

11.01.2022 – als Reaktion (Auszüge) auf die Aussage mit dem Status zur Implementierung der EPL-Weichen

Es gibt im Prinzip nur zwei Modi, die ich an den Ausgängen benötige, entweder das reine Schalten gegen Masse ODER Vcc für Doppelspulenantriebe oder ein Halbbrücke, die gegen Masse UND Vcc schalten können muss für Motorantriebe oder EPL.
Nichts von alle dem war beim eingesandten Modul möglich.

@Status der Implementierung für EPL-Weichen: ich sehe das Modul sehr stark auch für Großbahnen gedacht und deshalb habe ich mich auch dafür entschieden meine bestehenden 7 MX9 Module schrittweise auf StEin umzurüsten, was durch die Reduktion der Schienenausgänge nicht gerade “kosteneutral” ist. Der Vorteil der Punktmelder ist für mich nur am Papier vorhanden, da meine Anlage mit STP gesteuert wird und die Automatiken, funktionieren nur mit einem “echten” Abschnittswechsel.

@Eine Anleitung in Papier ist heute in vielen Fällen bei Geräten nur mehr sehr rudimentär dabei, oft nur mehr ein QR-Code oder link zur Webpage.
Dort sollte aber diese bitte aktuell sein und nicht nur in einer kleinen Sidenote stehen, was von der tollen Beschreibung alles nicht implementiert ist, und wie sich gezeigt hat, das unvollständig ist.

@Signale: sind ein optischer added Value für den Modellbahner, ich habe auch irgendwann bei mir im Garten angefangen Signale aufzustellen und freue mich nun darüber, wenn die richtig in STP eingetragen sind und entsprechend der Fahrstraßen leuchten. Umgekehrt ist es mir aber gleichgültig was diese anzeigen, wenn sich eine Weiche nicht bewegt, oder ein Zug in einem Abschnitt nicht fährt oder der Abschnitt falsch besetzt gemeldet wird.
Was ich damit sagen möchte ist, dass zuerst ein Zug fahren muss (siehe email-Diskussion um MX10 + MAN in Verwendung mit MX2/MX31), damit es notwendig ist auch den Fahrweg einzustellen, also das Schalten einer Weiche relevant wird. Und erst zum Schluss mache ich mir Gedanken ob die Signale so leuchten, wie gerade die Fahrstufe eingestellt ist.
Daher verstehe ich die Strategie bei der Implementierung nicht, wenn zuerst neue Signalbilder in den Fertig-Konfigurationen hinzukommen bevor noch alle Weichenmodelle angesteuert werden können.

@SW: das Einspielen der Parameter und Updates zentral zu machen ist im  Falle meiner Konfiguration auch ein sehr guter Ansatz, da ich nicht zu jedem Modul extra hinzugehen und anzustecken muss. Nur dazu muss ich sicher sein, dass nichts passieren kann, sonst habe ich unnötig viel mehr Arbeit damit. Ich kann mir beim besten Willen auch nicht unzählige Module in Reserve auf Lager legen oder Updates nur im Winter machen, wo ich die Anlage im Garten sowieso nicht in Betrieb habe.
Ein wenig mehr Möglichkeiten vom Start weg, zu wissen was eingestellt ist, wäre schon ungemein hilfreich. Wie ich beschrieben habe, ist es nicht möglich minimal die Nummern, der gewählten Fertig-Konfigurationen mit einer Prozedur, wie die z.B. Die SW-Version, am Display darzustellen. Es ist auch nicht möglich, irgendwie einen Reset auf den Auslieferungszustand zu machen (ist z.B. bei jedem Handy möglich). Es gibt keinen Bootloader oder ähnliches um ein Modul bei dem ein SW-Update schief gelaufen ist zu reanimieren (gabs doch bereits beim MX1) ….

29.12.2021 – Inbetriebnahme der Weichen

Das muss doch einfach “straight forward” möglich sein. Also den entsprechenden Adapter schnell gebaut, Weichenantrieb gesucht und angeklemmt. Und die nächste Enttäuschung und ein Tagelanges probieren und Rückfragen ohne Erfolg. Alles blinkt, STP oder auch direkt am Modul könnten die Weichen schalten, allein es tut sich gar nichts.
Aber wahrscheinlich hat dieses Modul auch einen anderen Defekt. Die geladene SW existiert nicht in der Doku auf der Zimo-Webseite. Die Fertig-Konfigurationen sind auch “beliebig” und haben gar nichts mit der Doku zu tun.

Es ist einfach ärgerlich, schon wieder das nächste Modul einsenden zu müssen.
Rückmeldung von Zimo (20.01.2022): 

Bzgl. der EPL Weiche:
Heute habe ich testweise versucht, einen EPL Weichenantrieb in Betrieb zu nehmen: Tatsächlich funktioniert das nicht! Danach habe ich mit dem Originalautor der Firmware, der im Ruhestand ist, telefoniert, und er hat mir bestätigt, dass das aus welchen Gründen auch immer nicht fertig implementiert wurde.

22.12.2021 – SW (*.bin) laden – Und jetzt geht NIX mehr.

Versuche Module auf den Letztstand der SW zu bringen, scheitern aus meiner Sicht an einem nicht vorhandenen Plausibilitätscheck, da sich auf dem USB-Stick auch noch ein *.bin File befand, was für das Booten vom Stick für Windows gehört.
DSC_1323
Module müssen zu Zimo zurück (23.12.2021 eingesendet)

11.12.2021 – MAN MX10 mit “alten” Fahrpulten MX2/MX31

unter dem Titel : Werkstattgeflüster gibt es einen Beitrag zur Inbetriebnahme
leider läuft es nicht so reibungslos wie gehofft, aber meine langjährige Erfahrung mit Zimo bestätigt mir das Gegenteil.

So ist nach langer Diskussion über den MAN-Modus derzeit die letzte Aussage von Zimo: “geht nicht (mit MX2/MX31 Fahrpulten mit MX10 & MX9/StEin”

Wenn Sie nur im CAN1.0 Protokoll am CAN unterwegs sind (sprich MX1, MX31, MX2, MX9 sind reine CAN1.0 Geräte) funktioniert MAN immer.

Wenn Sie nur im CAN2.0 Protokoll am CAN unterwegs sind (sprich MX10, MX32, MX32FU und StEin können CAN2.0) funktioniert MAN ebenfalls immer.”

 
DSC_1322

MAN in der Objekt-DB sichtbar, aber es kommt nicht auf der Schiene an.
(update 3.1.2022) es könnte doch ein Fehler in der SW sein. 

03.12.2021:

Das MX10 wird retour gesendet, die Inbetriebnahme kann weiter gehen.

25.10.2021:

Leider musste das MX10 zur “Verbesserung” zurück an Zimo gesandt werden, da die Achse des Drehknopf schief war.

DSC_1159

01.10.2021:

Das MX10EC und  je 2 Stück STEIN88V und STEIN88G habe ich am 02.04.2021 bestellt.

Aufgrund des Halbleitermangels oder anderer Bauteilverfügbarkeiten war das MX10EC bis Ende August 2021 noch immer nicht lieferbar. So wurde der Entschluss gefasst auf das MX10 zu wechseln, das dann bereits Ende September geliefert werden konnte.

01.06.2021: Vorarbeiten für das neue Digitalsystem

Der eine Schaltkasten unter der Föhre war schon immer zu klein, aber jetzt musste er getauscht werden. Siehe entsprechender Beitrag: Vom Chaos zur Ordnung

26.04.2021 – auf der “News”-Seite veröffentlicht

NEWS

2021:

Im Laufe des Jahres 2021 werde ich mein mehr als 15 Jahre im Einsatz befindliches Digitalsystem von Zimo erneuern, da manche der MX9 langsam in die Jahre kommen und diese mit dem neuen Basisgerät und den neuen StEin-Modulen in meinem Anwendungsfall nicht gemeinsam einsetzbar sind.
Daher wird es zu vereinzelten Betriebsausfällen kommen, wenn die geplante schrittweise Umsetzung nicht so läuft wie ich mir das vorstelle.
Die die Netzgeräte sind schon da, statt bisher 200W stehen dann ca. 1000W für das Fahren (mit Sound und Rauch) zur Verfügung. 
Mit den ersten Schritten, wird es auch die entsprechenden Beiträge oder eine eigene Seite zum Systemupdate geben.